Disable session timeout on CLI & PubSub+ Manager

Thomas Manson
Thomas Manson Member, Employee Posts: 10 Solace Employee
edited September 28 in Tips and Tricks #1

Hi Solace Community,

For obvious security reason the session timeout for the CLI & PubSub+ Manager is set to 5 minutes for CLI & 15 min for Manager.

And this can be annoying to have to reconnect all the time on non production environment or if you have a lot to do in production, for a "go live" for example.

CLI Session Timeout

on CLI, you can disable the session timeout for the current session (so you'll have to type it each time you want to disable it) :

session timeout 0

or change it definitively with the following

enable
configure
console timeout 120

PubSub+ Broker Manager

For the PubSub+ Broker Manager, you can permanently tune the session length.
The setting is done on the SEMP API session timeout, since the broker manager use the REST APi.

In PubSub+ Manager itself:

you can change it here :
System/service/Settings/SEMP/Session idle timeout

The maximum value is 5256000

Using CLI

enable
configure
service semp session-idle-timeout 5256000

**WARNING : ** This is something you shouldn't do in production (or restore default value once your go live is done)

Tagged:

Comments

  • marc
    marc Member, Administrator, Moderator, Employee Posts: 568 admin

    Thanks @Thomas Manson .....definitely a useful tip!

    I will say session timeout 0 was one of my best friends when using solace in dev environments ;)