Try PubSub+

Java RTO Issue - solclient_jni.dll: Can't find dependent libraries

amishraamishra Member Posts: 10
edited December 2019 in PubSub+ Event Broker #1

Hi Team ,
While trying to Run Java RTO Sample through Eclipse I am getting Exception
solclient_jni.dll: Can't find dependent libraries

Answers

  • amishraamishra Member Posts: 10

    I have added the Native DLL in Build Path and also tried passing it as VM arguement -Djava.library.path="Folder path of DLL"
    Please advise suggest regarding any additional configuration to run program through Eclipse or any other way to Run Java RTO Sample programs.

  • amishraamishra Member Posts: 10


    PLease refer above screenshot

  • AaronAaron Member, Moderator, Employee Posts: 202 Solace Employee

    Hi amishra..! Did you check the docs / tutorials? Does this help? https://solace.com/samples/solace-samples-javarto/publish-subscribe/

    I think you also need the native C libraries on your runtime path, since the JavaRTO is just a JNI wrapper around that.

    Curious: is there a reason you're not looking to use the standard Java (JCSMP) API?

    Thanks!

  • amishraamishra Member Posts: 10

    Hi Thanks !! I am able to Run it Now. I am using it to Publish/Subscribe Messages in Real Time.

  • karlkarl Member Posts: 1

    Hi, I am getting the same error:
    java.lang.UnsatisfiedLinkError: C:\project\solclient_jni.dll: Can't find dependent libraries
    And have my java.library.path system property set to the same directory.
    How were you able to resolve this issue?

Sign In or Register to comment.