Cant create more than 100 queues. solace docker image.

Options
akg17
akg17 Member Posts: 76

Cant create more than 100 queues.
Cant create more than 100 connection.

How can we extend it ?

Tagged:

Comments

  • TomF
    TomF Member, Employee Posts: 408 Solace Employee
    Options

    You're on the 100 scaling tier. You need to increase this - the 100 (default) tier allows 100 connections.

  • arih
    arih Member, Employee Posts: 125 Solace Employee
    Options

    As Tom said.

    But for lazy people like me who uses docker, I always start my new broker directly to 1000 scaling tier like this :)

    docker run -d -p xxxx:xxxx --shm-size=2g --env username_admin_globalaccesslevel=admin --env username_admin_password=admin --env system_scaling_maxconnectioncount=1000 --name=solace solace/solace-pubsub-standard

  • himanshu
    himanshu Member, Employee Posts: 67 Solace Employee
    Options

    You can use the instructions on this thread to upgrade to 1000 connection tier.
    https://solace.community/discussion/225/increasing-max-connection-limit-of-your-pubsub-broker#latest