Configure a non Transacted Router in JMS Tool Box

Options
slsbel
slsbel Member Posts: 13

Hello,

I'm trying to get access to a queue through JmsTool Box, but I'm getting the following error :

com.solacesystems.jcsmp.InvalidOperationException: Capability Mismatch: Router does not support transacted sessions.

Capability Mismatch: Router does not support transacted sessions.

The transacted mode is explicitly disabled.

How I can set Transacted to false in JmsToolBox?

Thank you.

Tagged:

Answers

  • slsbel
    slsbel Member Posts: 13
    edited March 2022 #2
    Options

    Message inserted by mistake in this section

  • slsbel
    slsbel Member Posts: 13
    Options

    To add more context to the question, if the "Use Transacted Session is enabled" in the client profile, Jms Tool Box work without an issue. if not (in our case) I'm getting the error :

    "Capability Mismatch: Router does not support transacted sessions."


    looking forward to any proposal on how can we use ToolBox with non transacted Solace router .

    Thank you.

  • azakovorotny
    azakovorotny Member Posts: 4
    Options

    I am facing the same problem when attempting to open a session with the local Solace, custom vpn.

  • Tamimi
    Tamimi Member, Administrator, Employee Posts: 499 admin
    Options

    Hey @slsbel and @azakovorotny - to use JMSToolBox with Solace you will have to enable transacted sessions on the Solace broker. Reason being is JMSToolBox requires transactions to delete "all" messages in a queue.