How to turn on keepalive for kafka connector

HI all, we are using both pubsubplus source and sink kafka connectors:

https://github.com/SolaceProducts/pubsubplus-connector-kafka-source


However, we hit the issue that connection drop from time to time and our VPN admin suggest that our connection don't have keepalive enabled, he send me this page for the keep alive interval and it should enabled by then:



However, it showing that even if we change the connection somehow it still don't have keepalive enabled, not sure what config we need to turn on? I also tried to add a number for connect / reconnect retry but it also doesn't help



Tagged:

Answers

  • marc
    marc Member, Administrator, Moderator, Employee Posts: 889 admin

    Hi @carfield,

    It looks like you have the proper settings there. You may want to consider setting them to -1 which would attempt to reconnect forever.

    When you say this, can you elaborate on where you are seeing keepalive is not enabled? Are you checking the logs to see if it's retrying?

     it showing that even if we change the connection somehow it still don't have keepalive enabled