Failed to retrieve configuration for syslog forwarding.

Hi Community,

I am trying to configure a syslog forwarding on a test broker of developer class and not able to retrieve it's configuration. It's showing contact support.

I have tried to configure the syslog forwarding using broker cli but looks like in console it's still showing inactive.

Kindly suggest solution for it or why it is getting failed. Your support is Appreciated.


Best Answer

  • techrahul95
    techrahul95 Member Posts: 19
    #2 Answer ✓

    Hi Aaron,

    I have received the response from Support. It seems like they have identified a bug in release 10.0 where maas-core has the wrong port configured to use for SEMP query to retrieve the syslog information.

    I have tried this using release 9.12 and this issue is not present. I hope this bug will be resolve in next release.

    Thanks.

Answers

  • Aaron
    Aaron Member, Administrator, Moderator, Employee Posts: 522 admin

    It should work? I just tried adding external Syslog forwarding on a dev broker. Maybe email Support then?

  • techrahul95
    techrahul95 Member Posts: 19

    Thanks Aaron,

    I have tried to refresh it few times still it was unable to retrieve the configuration details.

    I shall contact the solace support and let them know about it.

    Appreciated your help.

  • Aaron
    Aaron Member, Administrator, Moderator, Employee Posts: 522 admin

    I'm wondering what is broke? Let us know what Support says.

    If you have access to CLI, can you post your `show syslog *` output?

  • techrahul95
    techrahul95 Member Posts: 19

    Hi Aaron,

    I have checked the 'show syslog * ' output and Look's like it is configured there but somehow not visible in cloud console. It is working now.

    Thanks for your support.

  • techrahul95
    techrahul95 Member Posts: 19
    #7 Answer ✓

    Hi Aaron,

    I have received the response from Support. It seems like they have identified a bug in release 10.0 where maas-core has the wrong port configured to use for SEMP query to retrieve the syslog information.

    I have tried this using release 9.12 and this issue is not present. I hope this bug will be resolve in next release.

    Thanks.

  • Tamimi
    Tamimi Member, Administrator, Employee Posts: 491 admin

    @techrahul95 thanks for the update and follow up on this !

  • techrahul95
    techrahul95 Member Posts: 19

    Hi @Tamimi,

    Happy to help the Awesome Solace community. Appreciate your support.

    Regards,

    Rahul.