Change max message size for mqtt queues

Options
jesper
jesper Member Posts: 8

Hello community,

i am using enterprise 10K broker in the cloud.

Is it possible to change the setting for maximum message size of mqtt persistant queues? I want to set this config with an solace admin user and not in the client implementation.


I tried it via the solace cli, but it is not allowed to set up the queues:

ERROR: The #mqtt/a9828ccf17714b4b94fbe55d44b1c9d8/250 queue may not be configured.

ERROR: Cannot enter queue mode: not allowed.


Do you have any further ideas?

Best regards

Jens

Best Answer

  • uherbst
    uherbst Member, Employee Posts: 123 Solace Employee
    #2 Answer ✓
    Options

    Hi @jesper ,


    sure we have further ideas :-)

    If you want to set configuration details on MQTT-queues, you need to create a queue-template with your specific settings (for example: max message size, or TTL, or queue quota) and enable queue-templates in the client-profile(s) for the mqtt-user(s).


    If you need more specific explanations, ping me.


    Uli

Answers

  • uherbst
    uherbst Member, Employee Posts: 123 Solace Employee
    #3 Answer ✓
    Options

    Hi @jesper ,


    sure we have further ideas :-)

    If you want to set configuration details on MQTT-queues, you need to create a queue-template with your specific settings (for example: max message size, or TTL, or queue quota) and enable queue-templates in the client-profile(s) for the mqtt-user(s).


    If you need more specific explanations, ping me.


    Uli

  • jesper
    jesper Member Posts: 8
    edited December 2022 #4
    Options

    Thank you very much, Uli!

    Schöne Grüße aus Mannheim

    Jens