NoClassDefFoundError - SolJNDIInditialContextFactory - need assistance

Options
shashi
shashi Member Posts: 5

Hi TEam,

I am java developers, if I am using the sol-jms-10.3.1.jar or sol-jms-10.3.1.jar I am able to connect to the Solace VPN

If I tried to use the sol-jms-10.6.2.jar - I am getting the below error :

NoClassDefFoundError - cloud not load class com.solacesystems.jndi.SolJNDIInditialContextFactory 

Am I missing anything here ?

Would you please assists.

Tagged:

Comments

  • Aaron
    Aaron Member, Administrator, Moderator, Employee Posts: 541 admin
    Options

    Hi @shashi... 10.6.2 came out almost 4 years ago. Can you try with a recent version (e.g. 10.19.0) and see if you are experiencing the same issue? Thanks.

    But I don't know why you would be seeing that error if 10.6.2 was loaded and on the classpath properly..?

  • shashi
    shashi Member Posts: 5
    Options

    Hi Aaron,

    Thanks for your reply

    We are migrating to PCF cloud, our legacy application runs in Weblogic container with JRockit jdk1.6, we need to send the message from legacy application to PCF till end of this year, but it runs on JRockit jdk1.6

    if I am using the sol-jms-10.3.1.jar or sol-jms-10.3.2.jar I am able to connect to the Solace VPN, if I updagraed the jar above sol-jms-10.3.2.jar - I am getting the below error :

    NoClassDefFoundError - cloud not load class com.solacesystems.jndi.SolJNDIInditialContextFactory 

    Is the 10.19.0 version compatible with JRockit jdk1.6 ?

    Thanks

  • Aaron
    Aaron Member, Administrator, Moderator, Employee Posts: 541 admin
    Options

    Hey @shashi... there is no Solace JMS 10.3.2 library that I can see? https://mvnrepository.com/artifact/com.solacesystems/sol-jms

    I checked the release notes of some previous versions... it looks like 10.10 was the last version that supported JDK 1.6:

    Solace is deprecating support for Java versions 1.6 and 1.7 with the intention that future releases of the Java API (JCSMP) will NOT be supported on Java versions prior to 1.8. Java versions prior to 1.8 are not supported by Oracle or OpenJDK making it impossible for Solace to maintain support for older versions of the language.

    Release 10.10 will be the last Solace Java API version that supports versions prior to Java 1.8.

    Hope that helps. If 10.10 doesn't work, I'm pretty sure 10.9 will.