solace-pubsubplus is not getting installed in python:3.8.0-alpine3.10

Shijo
Shijo Member Posts: 9 ✭✭

Trying to install the solace-pubsubplus==1.6.0 into the python3.8.0-alphine3.10 inside the docker

ERROR: Could not find a version that satisfies the requirement solace-pubsubplus==1.6.0 (from versions: 0.2.0, 0.2.1)
ERROR: No matching distribution found for solace-pubsubplus==1.6.0
error building image: error building stage: failed to execute command: waiting for process to exit: exit status 1

Can anybody help on this?

Comments

  • Shijo
    Shijo Member Posts: 9 ✭✭

    Follow up for the same,

    anyone facing the same issue? is there any solution for the same?

  • Tamimi
    Tamimi Member, Administrator, Employee Posts: 488 admin

    Hey @Shijo - can you please upgrade pip before attempting to install the solace API and confirm if you are still having the same issue? Thanks!

  • Shijo
    Shijo Member Posts: 9 ✭✭

    @Tamimi Thanks for the response.

    The solace-pubsubplus will not be supported in the Alpine versions. Should use the non-Alpine python version.

    Got an official confirmation from the solace, and my problem also resolved by using the non-Alpine python version.

  • Tamimi
    Tamimi Member, Administrator, Employee Posts: 488 admin

    Perfect - thanks for the update on this @Shijo ! Keep an eye on the community as we announced future Python API updates for other platforms support