Could not load file or assembly 'SolaceSystems.Solclient.Messaging, Version=10.23.0.0 in container.

shaunvdberg
shaunvdberg Member Posts: 14 ✭✭

Hi

Thank you Solace team - I was very excited with the release of version 10.23, as this now supports the Mac series M processors. I am now able to build event driven dotnet applications on my Mac M2, using rider, without issues.

However, when dockerizing these applications & running the container locally on my M2, I still get the following error within my running container:

Could not load file or assembly 'SolaceSystems.Solclient.Messaging, Version=10.23.0.0, Culture=neutral, PublicKeyToken=e191a36e57c23464'. The system cannot find the file specified.

This was the exact error I got prior to the 10.23 upgrade. I tried build the image and running the container locally using rancher desktop and docker desktop.

Any ideas?

Appreciate the help.

Shaun

Tagged:

Answers

  • Ragnar
    Ragnar Member, Employee Posts: 64 Solace Employee

    Hi Shaun,

    When you run in a docker container you are running in a Linux environment, not a MacOS environment. Support for .NET in Linux-ARM is scheduled for March 15, 2024 (release 10.24.0).

    Regards

    Ragnar

  • shaunvdberg
    shaunvdberg Member Posts: 14 ✭✭

    Hi @Ragnar

    Thanks for the update. I was not aware that Linux-ARM support was still outstanding.

    Thanks

    Shaun