Try PubSub+

How to specify a specific JCSMP or JMS version when using the Solace Spring Boot Starters

ngdavid1013ngdavid1013 Member Posts: 1

Sometimes, you may have a particular JMS load that you want to use in Spring Boot. For example, when you need to duplicate an issue experienced by a client. This is the procedure:
Edit the POM file with the following two sections:
1) In the dependencies section for the artifact solace-jms-spring-boot-starter, exclude the sol-jms artifact. This causes the solace-jms-spring-boot-starter not to load the sol-jms artifact.
2) Next add a new dependency for your version of sol-jms.
The following is a section of the POM file after modifications:

    <dependency>
        <groupId>com.solace.spring.boot</groupId>
        <artifactId>solace-jms-spring-boot-starter</artifactId>
        <version>3.2.0</version>
        <exclusions>                    <------------------------------------- New (1)
            <exclusion>
                <groupId>com.solacesystems</groupId>
                <artifactId>sol-jms</artifactId>
            </exclusion>
        </exclusions>
    </dependency>
    <dependency>                        <--------------------------------- New (2)
        <groupId>com.solacesystems</groupId>
        <artifactId>sol-jms</artifactId>
        <version>my-special-version</version>
    </dependency>​

Comments

Sign In or Register to comment.