Try PubSub+

SolaceSystems.Solclient.Messaging.OperationErrorException

In my application I am creating a solace message "CreateMessage()". After that i am converting message to stream using "SolaceSystems.Solclient.Messaging.SDT.SDTUtils.CreateStream(solaceMessage, 10240)".
While writing in stream in a loop I am getting below exception after some iteration in the loop.

"SolaceSystems.Solclient.Messaging.OperationErrorException: 'Failed to add string field in IStreamContainer with value: "
Can you please help why i am getting this error?

P.S. I have already set "SocketReceiveBufferSizeInBytes" to 1024*1024.

Thanks,
Prasoon

Comments

  • AaronAaron Member, Moderator, Employee Posts: 124 Solace Employee

    Hi @prasoonSolace ..! Value looks blank... are you trying to insert an empty String? I'm not sure that's allowed in a SDTStream..?

    Also, I'm just curious why you are using the Solace SDT type? I mean, they're useful and all, but they are a Solace-specific format. So if you want to use non-Solace APIs (e.g. MQTT, AMQP, etc.) then they wouldn't be able to decode. Usually people are just using JSON or YAML or Google ProtoBufs or something instead, attaching them as a TextMessage or BtyesMessage, rather than using the SDT StreamMessage. Thoughts?

  • prasoonSolaceprasoonSolace Member Posts: 9

    Hi,
    My problem got solved. The issue was, in between the code new stream was getting created and in that new stream SDT field was added because of which issue was coming. After rectifying that my problem got solved.

Sign In or Register to comment.