Try PubSub+

Falling with Solace PubSub+ for Docker

sandeep_rsandeep_r Member Posts: 5
edited October 4 in General Discussions

Hi, I am trying to setup solace running in a docker container, when I started with the below commands. it is falling to start?

Any help would be appreciated, please.

sudo docker run -d -p 8080:8080 -p 55555:55555 --shm-size=2g --env username_admin_globalaccesslevel=admin --env username_admin_password=admin --name=solace solace/solace-pubsub-standard
Unable to find image 'solace/solace-pubsub-standard:latest' locally
Trying to pull repository registry.access.redhat.com/solace/solace-pubsub-standard ...
Trying to pull repository registry.redhat.io/solace/solace-pubsub-standard ...
Trying to pull repository docker.io/solace/solace-pubsub-standard ...
Trying to pull repository docker.io/solace/solace-pubsub-standard ...
/usr/bin/docker-current: Get https://registry-1.docker.io/v2/: net/http: request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers).
See '/usr/bin/docker-current run --help'.

Tagged:

Comments

  • himanshuhimanshu Member, Employee Posts: 24 Solace Employee

    Hi @sandeep_r - are you trying to run the container on your personal desktop/laptop or at work? The error you are getting is due to docker not being able to connect to the internet to download the image. This issue is discussed here.

    To confirm, you can try running docker pull hello-world and if that fails, it will verify that this is a docker issue.

  • sandeep_rsandeep_r Member Posts: 5

    Thanks, Himanshu for your prompt response.
    My assumption this is a proxy error. not able to reach to internet. How to add proxy over here?
    I have proxy like : export {http,https,ftp}_proxy="http://xyz.com:9090" ( i usally use when i downloaded from internet like wget https://products.solace.com/download/PUBSUB_DOCKER_STAND )

    FYI
    docker pull hello-world
    Using default tag: latest
    Trying to pull repository registry.access.redhat.com/hello-world ...

  • himanshuhimanshu Member, Employee Posts: 24 Solace Employee

    I am not too sure about how to resolve this but Docker's docs do mention how to setup the proxy config:
    https://docs.docker.com/config/daemon/systemd/#httphttps-proxy

  • sandeep_rsandeep_r Member Posts: 5

    Hi,

    I have an image locally and I can able to see images in docker images, but I am still having difficulties in running this?

    Any help would be appricated.

    [[email protected] ~]# docker images
    REPOSITORY TAG IMAGE ID CREATED SIZE
    solace-pubsub-standard 9.7.0.29 b33ff7f97529 7 days ago 1.01 GB
    [[email protected] ~]#sudo docker run -d -p 8080:8080 -p 55555:55555 --shm-size=1g --env username_admin_globalaccesslevel=admin --env username_admin_password=admin --name=solace solace/solace-pubsub-standard
    Unable to find image 'solace/solace-pubsub-standard:latest' locally
    Trying to pull repository registry.access.redhat.com/solace/solace-pubsub-standard ...
    Trying to pull repository registry.redhat.io/solace/solace-pubsub-standard ...
    Trying to pull repository docker.io/solace/solace-pubsub-standard ...
    Trying to pull repository docker.io/solace/solace-pubsub-standard ...
    /usr/bin/docker-current: Get https://registry-1.docker.io/v2/: net/http: request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers).
    See '/usr/bin/docker-current run --help'.

  • sandeep_rsandeep_r Member Posts: 5

    I tried adding proxy at

    $ sudo mkdir -p /etc/systemd/system/docker.service.d
    $ sudo vi /etc/systemd/system/docker.service.d/http_proxy.conf
    [Service]
    Environment="HTTP_PROXY=http://:/"
    $ sudo vi /etc/systemd/system/docker.service.d/https_proxy.conf
    [Service]
    Environment="HTTPS_PROXY=http://:/"
    $ sudo systemctl daemon-reload
    $ sudo systemctl restart docker

    ###################################33

    and updated
    sudo vi /etc/resolv.conf

    nameserver 8.8.8.8

    nameserver 8.8.4.4

    run following commands to restart daemon and docker service

    sudo systemctl daemon-reload

    sudo systemctl restart docker

    ############################################3

    Here is latest Error:

    sudo docker run -d -p 8080:8080 -p 55555:55555 --shm-size=1g --env username_admin_globalaccesslevel=admin --env username_admin_password=admin --name=solace solace/solace-pubsub-standard

    Unable to find image 'solace/solace-pubsub-standard:latest' locally
    Trying to pull repository registry.access.redhat.com/solace/solace-pubsub-standard ...
    Trying to pull repository registry.redhat.io/solace/solace-pubsub-standard ...
    Trying to pull repository docker.io/solace/solace-pubsub-standard ...
    Trying to pull repository docker.io/solace/solace-pubsub-standard ...
    /usr/bin/docker-current: Get https://registry-1.docker.io/v2/: proxyconnect tcp: dial tcp: lookup http on 8.8.8.8:53: no such host.
    See '/usr/bin/docker-current run --help'.

  • himanshuhimanshu Member, Employee Posts: 24 Solace Employee

    Given that you have the image, try using it to run the docker container:
    sudo docker run -d -p 8080:8080 -p 55555:55555 --shm-size=1g --env username_admin_globalaccesslevel=admin --env username_admin_password=admin --name=solace b33ff7f97529

  • sandeep_rsandeep_r Member Posts: 5

    you made my day, it is working now, thank you so much for your kind help.

  • himanshuhimanshu Member, Employee Posts: 24 Solace Employee

    @sandeep_r said:
    you made my day, it is working now, thank you so much for your kind help.

    I am glad it worked!

Sign In or Register to comment.