Try PubSub+

Pub-Sub+ Standard 9.7.0.29 issues when starting the container

CloudGodCloudGod Member Posts: 7

Hi everyone,
I wanted to retry to set up a broker today over Oracle Linux and there's a new version of the PubSub+ Standard broker (9.7.0.29).
As I'm using Solace's GCP Quickstart guide to do my broker instantiations, I use the install script provided.
Everything ran smoothly in the past, but not today. :)
In this new version, the 1.000 connection limit is enforced during the container start, and it fails if the environment configuration is set with maxconnectioncount > 1000.
I used to try out the standard broker with a 2 thread 16 Gb ram typical setup and that validation wasn't enforced during the container start (at least it wasn't on 9.6.0.38).
If you also use the install-solace.sh script on that quickstart, just change it to have the maxconnectioncount capped at 1000 even if you have a lot of memory available.
I created a Pull Request with the fix. Hopefully, this will be incorporated in the script so that we don't need to worry about this.
HTH
Cheers
Jose

Comments

  • pkondratpkondrat Member, Employee Posts: 10 Solace Employee

    Hi Jose,
    With 9.7, we started enforcing the resource requirements more strictly. The standard edition does not support greater than 1000 maxconnectioncount (that has always been true). To run more than 1000 connections, you will also need more than two cores. I suspect this is what is stopping you if you are trying to use PubSub+ Enterprise or PubSub+ Enterprise Evaluation with 2 cores and 16GB at greater than 1000 connections. The following pages in our documentation describe the resource requirements:
    https://docs.solace.com/Configuring-and-Managing/SW-Broker-Specific-Config/System-Resource-Requirements.htm
    https://docs.solace.com/Configuring-and-Managing/SW-Broker-Specific-Config/System-Scaling-Parameters.htm
    Best Regards,
    Paul

  • CloudGodCloudGod Member Posts: 7

    Hi Paul,
    I'm trying to use the PubSub+ Standard, not the enterprise. I'm just conducting a few tests over Oracle Linux, so the single core was enough.
    I'm using Solace's GCP Quickstart for PubSub+ Standard as a guide (https://github.com/SolaceProducts/pubsubplus-gcp-quickstart). It has an install-solace.sh script, which sets up solace and gets it running. In it, the max number of connections was only defined by the amount of memory available.

    Previously, the broker didn't fail and exited if the supplied maxconnectioncount container environment variable exceeded 1000 in the Standard edition. It now fails, and the broker doesn't run.

    As the quickstart script uses the Standard edition anyway, that script should cap the maxconnectioncount to 1000 no matter the amount of memory available in the machine.

    To be honest, I always thought the cap on the Standard edition was inside the engine, and no matter what was supplied as a maxconnectioncount, it never handled more than 1000 connections.

    IMHO, this container shouldn't fail the way it does. It's just a limits config. The container works fine even with higher values, as it worked on previous versions.

    What it should do, is enforce the max connection count as per the Standard Licence, meaning that even if I supply a higher number, it would check and cap at 1000. That Cap should be informed in the logs, something along the line of this:
    Install log excerpt:
    2020-10-11T08:43:13Z machine-name /usr/sbin/confd[69]: WARNING "Solace PubSub+ Standard Edition does not support 10000 connections.\n"
    2020-10-11T08:43:13Z machine.name /usr/sbin/confd[69]: WARNING "The system will default to a maximum of 1000 connections. \n"

    But definitely, never fail and exit, as it does now.
    Install log excerpt (as seen today):
    2020-10-11T08:43:13Z machine-name /usr/sbin/confd[69]: ERROR "Solace PubSub+ Standard Edition does not support 10000 connections.\n"
    2020-10-11T08:43:13Z machine.name /usr/sbin/confd[69]: ERROR Config check failed: exit status 1

    Cheers
    Jose

  • pkondratpkondrat Member, Employee Posts: 10 Solace Employee

    Hi Jose,
    I was unaware that attempting to set the maxconnectioncount to a value greater than 1000 with the standard edition was changed to an error in 9.7. I was unaware that the GCP Quickstart relied on the previous behavior. Thank you for bringing this to our attention.
    Best Regards,
    Paul

  • marcmarc Member, Administrator, Moderator, Employee Posts: 194 admin
    edited October 12

    Thanks @CloudGod for catching & troubleshooting this! And double thanks for opening the PR with a fix!

  • BalazsBalazs Member, Employee Posts: 2 Solace Employee

    Hi Jose, thank you for raising this. There is a fix underway which will enable selecting the scaling parameters with defaults that work for the Standard edition

Sign In or Register to comment.