Cannot connect JMS Toolbox - Unauthorised access

Poornima Member Posts: 25

I have downloaded JMSToolbox and trying to configure for queue browsing and i have provided 2 set of credentials both Client username /password in Connection tab and management username and password in Properties tab. I get this error. Can anyone help



  • amackenzie
    amackenzie Member, Employee Posts: 260 Solace Employee
    edited December 2020 #2

    as you mention, there are 2 sets of credentials you need to provide for JMSToolbox. 1 is a client username set up on the broker that has the privileges to do messaging and another which is a management user that has the rights to manage brokers. And the URL for the management user needs to be the same as you use for PubSub+ Manager like http[s]://[broker DNS name or IP]:[management port default 8080]
    I can only assume without more info that one of your users does not have the necessary privs to carry out the JMSToolbox tasks.

  • Poornima
    Poornima Member Posts: 25

    I have fixed it already thanks for getting back

  • ShivaPrasad
    ShivaPrasad Member Posts: 12

    Hi ,
    When I try to connect JMS Toolbox with ssl connection, I am getting an following error message unable to find valid certification path to requested target
    unable to find valid certification path to requested target
    But I have provide my .jks path correctly as per the document (C:/Demo/truststore.jks) and the trust store format and passowrd.
    Appreciate,If someone help me on this.

  • marc
    marc Member, Administrator, Moderator, Employee Posts: 935 admin

    Hi @ShivaPrasad,
    Can I get you to please create a separate post for this question? Also, these SSL issues can sometimes be tricky to troubleshoot. Can you share a bit more info about the broker you're trying to connect to? For example, is it a local docker, Messaging Service in PubSub+ Cloud, etc?


  • VvT
    VvT Member, Employee Posts: 15 Solace Employee

    This problem occurs when the machine where JMSToolbox is installed is using a proxy like zscaler. Can you check if you're using a proxy and try to disable it?