Try PubSub+

Solace and Boomi Deployment

PoornimaPoornima Member Posts: 21

Hi All,
I am facing some issues related to the deployment in Boomi for Solace Pubsub connector.
I am using Solace Pubsub+ Connector. Whenever I deploy to Test cloud Atom Listening operation is failing. I installed required jar files in Atom cloud but still I get below error,
Can any one guide if I need to set some properties to avoid below error.
Encountered an error while initializing LISTEN operation.: com.solacesystems.jcsmp.InvalidPropertiesException: Unable to load trust store: /usr/java/jdk1.8.0_261/jre/lib/security/cacerts; Caused by: Unable to load trust store: /usr/java/jdk1.8.0_261/jre/lib/security/cacerts; Caused by: access denied ("java.io.FilePermission" "/usr/java/jdk1.8.0_261/jre/lib/security/cacerts" "read") (from Mon Dec 21 16:24:06 UTC 2020)

Comments

  • TomFTomF Member, Employee Posts: 182 Solace Employee

    Hi @Poornima, it looks like you're trying to connect to Solace using a secure connection. To do this, you need to set up your security settings such as where your trust store is.
    It might be easier to try connecting using plain text first to verify the connection can be made.

  • sjaaksjaak Member Posts: 41 ✭✭

    The Solace connector requires "Secure listen" functionality. The connector is not yet compatible with multi-tenant (Private) Atom Clouds. It runs fine on a local run-time (Atom) or a HA run-time (Molecule). We've reported the issue to both Solace and Boomi last October.

    See https://help.boomi.com/bundle/connectors/page/int-Implementing_secure_listen.html for more information

Sign In or Register to comment.