Port 55555 blocked at MacOS Big Sur

Options
FalkLademann
FalkLademann Member Posts: 8
edited February 2021 in Tips and Tricks #1

Solace default SMF port 55555 apparently is blocked under MacOS Big Sur.
The issue is a bit irritating, as the port won't show up in any listing for ports in use.

Existing templates start silently to fail on simple things like Try-Me with ws protocol (as underlying SMF is not available).
New templates will not start with a "port in use" error.

See
https://apple.stackexchange.com/questions/410987/port-55555-on-mac-os-big-sur-already-in-use
https://developer.apple.com/forums/thread/671197
for reference.

Maybe it might be a good idea to create a hint in the docs
https://docs.solace.com/Solace-SW-Broker-Set-Up/Docker-Containers/Set-Up-Docker-Container-macOS.htm
and to this Docker compose template?
I've fixed this by mapping port 55555 to 55566 in docker-compose.yml

Comments

  • TomF
    TomF Member, Employee Posts: 406 Solace Employee
    Options

    Hi @FalkLademann, yes, you're right. I'll ask for the docs to include a note - thanks!

  • marc
    marc Member, Administrator, Moderator, Employee Posts: 923 admin
    Options

    Thanks @FalkLademann, thanks for bringing this to our attention. We'll also look at updating it in docker compose and other places that talk about using the docker container.

  • TomF
    TomF Member, Employee Posts: 406 Solace Employee
    Options

    @FalkLademann a quick update - it looks like the docs team will be adding a note. Thanks for the reminder.

  • Wippet Boy
    Wippet Boy Member Posts: 2
    Options

    Hi,

    I've been running through some samples today and came across this Mac issue :(

    When running the Java samples do I need to make a change if running on a port other than 55555

  • Wippet Boy
    Wippet Boy Member Posts: 2
    Options

    I answered my own question and its a yes :). SO I'm all good for now. Up and running B)

  • marc
    marc Member, Administrator, Moderator, Employee Posts: 923 admin
    Options

    Correct, thanks @Wippet Boy! For others that find this: By default Solace SMF APIs will try to connect to localhost:55555 so you would have to change the port to localhost:<PORT>