JMSToolbox : Unable to see the content of the message when I Click on Browse Queue Option

Options
ShivaPrasad
ShivaPrasad Member Posts: 12

Could you please help me on this issue. I am using Solace PubSub Event Broker message VPN.
Step1 : I have used sdkpref to send message to Queue ( e.g abc) and sent 3 messages to the Queue
Step2 : I have logged in Soldadmin and Could see message spooled is 3
Step3 : I have connected messageVPN using JMSToolBox and Could see my Queue name (abc) is listed under SolaceQManager tree view (Under Queues)
Step4 : I did the right click and Selected Browse Queue option but unable to retrieve the message spooled using JMSToolBox. I should be expecting 3 messages to be displayed but empty screen is displaying.
I could see following messages in the log file
browseQueue JTBQueue [abc] maxMessages=200, payloadSearchText='' selectorsSearchText=''
Q Depth : null Max : 200 Nb msg to display : 0
May I know the reason why JMSToolbox is not showing the message spooled on the Queue. Am I missing something here ? . Appreciate , your help on this
Thanks
Shiva

Comments

  • amackenzie
    amackenzie Member, Employee Posts: 260 Solace Employee
    Options

    Hi, can you share the SDKPerf command line you used to publish the messages?

  • ShivaPrasad
    ShivaPrasad Member Posts: 12
    Options

    Here is the command working . I've replaced all the below values as per my pubsub VPN configuration and able to publish message to topic which has Queue endpoint subscribed to this topic.
    sdkperf_java.bat -cip=tcps://ipaddress:portnumber, -cu=Username@VPNName -cpf= -sslts= -ssltsp= -ssltsf=jks -sslp=TLSv1.2 -stl= -ptl=Topicname –mn=1 -msa=10 –md
    Thanks
    Shiva

  • amackenzie
    amackenzie Member, Employee Posts: 260 Solace Employee
    Options

    thanks, just to confirm...
    queue abc has a subscription to "Topicname" in the -ptl?
    can you add -mt=persisitent to the sdkperf? it shouldn't matter but wouldn't hurt.
    Is the username in JMSToolbox the same as the username in sdkperf?
    could you try publishing directly to the queue with -pql=abc?

  • nram
    nram Member, Employee Posts: 80 Solace Employee
    Options

    Hi @ShivaPrasad ,
    1) Do you have any TTL set on the Queue ?
    2) Can you try to browse with sdkperf itself (-qb -sql=QueueName) to eliminate if its tool (JMSToolbox) issue ?
    // nram

  • ShivaPrasad
    ShivaPrasad Member Posts: 12
    Options

    Yes. TTL set on the Queue.
    I tried by adding -sql= to my sdkperf and I am able to consume messages from queue.
    I have verified message spooled count is 0 in Soladmin after running sdfperf command.
    Thanks
    Shiva

  • nram
    nram Member, Employee Posts: 80 Solace Employee
    Options

    Hi @ShivaPrasad ,
    Whats the TTL value on the Queue? Is it likely you are browsing with JMSToolbox after the messages expired ?
    // nram

  • ShivaPrasad
    ShivaPrasad Member Posts: 12
    Options

    TTL is 7 days (in seconds) . I am able to browse the queue content using -sql= -qb -md -q using sdfperf. My assumption is that if Click on Browse Queue option on JMSToolBox, The same message should display but no messages displayed on the screen. It is showing the below logs in jmstoolbox logs
    Q Depth : null Max : 2147483647 Nb msg to display : 0
    Thanks
    Shiva

  • nram
    nram Member, Employee Posts: 80 Solace Employee
    Options

    Then it appears to be a tool issue (JMSToolBox). What version of JMSToolBox and SolOS are you working with? Few general comments:
    1) Pl make sure you are using latest version of JMSToolBox.
    2) You may also add latest Solace JARs to JMSToolBox with "Configure Q Manager" in case
    3) Pl check this video out: https://www.youtube.com/watch?v=I-AzudvPaGg
    // nram

  • ShivaPrasad
    ShivaPrasad Member Posts: 12
    Options

    Thank you nram for your response. Greatly appreciated. I've verified SolOS and installed the latest version as per the pre-requisites. Everything looks ok. The actual issue is there is a variable - browser_timeout : Minimum value: 250 milliseconds when I establish a connection . I've modified this value to 1000 milliseconds. Then I am able to see the messages on the browser. JMSToolBox is not able to retrieve the messages from VPN within 250 ms.
    Thanks
    Shiva

  • marc
    marc Member, Administrator, Moderator, Employee Posts: 923 admin
    Options

    Glad you figured it out @ShivaPrasad and thanks for letting us know!
    @amackenzie, what do you think about changing the default value of browser_timeout to 1000ms or maybe even something like 3000ms?

  • amackenzie
    amackenzie Member, Employee Posts: 260 Solace Employee
    Options

    We can look at it. To be clear, the 250ms is the default for JMSToolbox's PubSub+ broker plugin. The default in the Java API is 10000ms (10 sec). I am not sure why 250ms was chosen for JMSToolbox.