Not getting data from Queue while consumed using Spring Boot ,But Solace end its showing data sent

dola
dola Member Posts: 5

I am facing while consume(""q-51685-stavi-pymt-rtgs-outward") the data from Solace queue not getting any data , but in Solace its showing data consumed , its happening in System integration Testing.
While publishing we are able to publish the data in 2 different topics to Solace.
Already 2 days gone our solace team also not able to find where is fault.

But in POC able publish("v1/stavi/test/conn/-/pub") the message and consume( "q-stavi-test-conn") the message .POC is successful.

Please help .

Answers

  • marc
    marc Member, Administrator, Moderator, Employee Posts: 568 admin

    Hi @dola,

    It sounds like you are publishing to topics and consuming from queues. Is that correct?

    If so make sure you check what topic subscriptions are on the queue that you are consuming from. You can do this in PubSub+ Manager.

    Another item that might trip you up is if the publisher and consumer are connecting to different message vpns or services so you might want to double check that as well. A good test would be to use the "Try-Me" tool or sdkperf to subscribe to the topic you are publishing to and make sure it receives the messages as well.

    Hope that helps!

  • dola
    dola Member Posts: 5

    Hi Marc,
    Thanks for your response.
    I am not publishing to topics only consuming from queue(q-51685-stavi-pymt-rtgs-outward) , from systems data are coming to respective topics .
    As per requirement i am sending to ackNack topics"ackNack" , bot not able to get data from "q-51685-stavi-pymt-rtgs-outward" in SIT

    Thanks
    Dola

  • marc
    marc Member, Administrator, Moderator, Employee Posts: 568 admin

    Hi @dola,

    If I understand correctly you are trying to consume from the "q-51685-stavi-pymt-rtgs-outward" queue and other systems are publishing to the "ackNack" topic. Can you verify that your "q-51685-stavi-pymt-rtgs-outward" queue has a topic subscription to the "ackNack" topic?

  • dola
    dola Member Posts: 5

    Hi marc,
    q-51685-stavi-pymt-rtgs-outward has other topic "outward-topic" , other systems are sending data to "outward-topic", i am consuming the "q-51685-stavi-pymt-rtgs-outward" , but not getting any data .But solace end its showing data are sending .

  • marc
    marc Member, Administrator, Moderator, Employee Posts: 568 admin

    What do you mean when you say "solace end its showing data are sending" ?

    A few things to check:

    • Does the queue have any messages on it?
    • Check the queue stats and see if that gives you any hints. Are messages expiring? Are messages not being queued for some reason? etc.
    • Is the queue exclusive or non-exclusive? If it's exclusive only the first consumer will receive messages
  • Tamimi
    Tamimi Member, Administrator, Employee Posts: 228 admin

    Hey @dola, as marc mentioned there are a couple of things to check

    • From the broker: queue stats, queue topic subscription, queue configuration (exclusive vs nonexclusive)
    • From the consumer: what VPN is your consumer connected to, how many consumers are bound to the queue

    You also mentioned your POC is successful; so what I understand is you are publishing to topic v1/stavi/test/conn/-/pub, your queue (is it called q-stavi-test-conn?) on the broker is subscribed to this topic and a consumer is bound to the queue and consuming the messages?

  • dola
    dola Member Posts: 5

    Thanks marc and Tamini for feedback.

    Here problem was from publisher end other system who was publishing not following the standard msg types .
    Here as per requirement that should be String but instead of String without any information other system was publishing as a Binary format . So its not receiving from "v1/stavi/test/conn/-/pub" queue .

    So we need to be careful about message Type while integration happened with other systems.

    Its resolved today after so many discussion .This was the drawback of Project Manager which has not shared the details to receiver vendor .Faced this issue one of the largest bank SCB.

    Regards,
    Dola

  • Tamimi
    Tamimi Member, Administrator, Employee Posts: 228 admin

    aah okay makes sense, I am glad you were able to resolve your issue!