Boomi Solace Connector: Send operation failed due to maximum size limit

Poornima
Poornima Member Posts: 25 ✭
edited October 2021 in Connectors & Integrations #1

Hi,

I am using Boomi and Solace Connector. I am gtting information from Database and mapping to XML profile and trying to push xml to Solace queue (Send) operation. Just 2000 db records it was erroring as

Error : [400] SEND's operation combined incoming documents exceed allowed size of [ 1048576 bytes ]. .

Did we have any settings in Solace queue to increase allowable size ? I set message queued Quote to 20k.

Tagged:

Comments

  • Aaron
    Aaron Member, Administrator, Moderator, Employee Posts: 483 admin

    Hey @Poornima. Is that a Solace error, or a Connector error? It doesn't look familiar to me..? "SEND's operation" ..?

    That said, the default maximum message size for queues in Solace 10MB. So there shouldn't be any setting necessary to publish a message that is only 1MB big. And the default queue quota size is 1.5GB, so it shouldn't be that either.

    Only thing to check: if you have created a Message VPN (i.e. not using the default one), then you need to set the max quota for your VPN specifically... that defaults to 0MB.

    But if you're able to publish smaller messages, then that's probably not it.

    Any chance you can enable more detailed logging (e.g. debug level) that might give more clues..?

    Also, have you raised with Boomi team?

  • nram
    nram Member, Employee Posts: 80 Solace Employee

    Hello @Poornima , Agree with @Aaron .. this doesn't look like Solace error. There are two kinds of large message threshold related events you can possibly get from Solace. 1. when "max message size" set on the queue is breached. This will be "Document too large" exception thrown to the publisher. 2. when "large message size" set on VPN is breached. This is a warning logged on Solace end (CLIENT_CLIENT_LARGE_MESSAGE), but the send operation itself is not blocked. The error log you provided dosen't seem to match either.

  • cmorneau
    cmorneau Member, Employee Posts: 7 Solace Employee

    The size limit comes from the Atom configuration.

    By default, the SEND operation is not allowed to process documents larger than 1MB. This is a requirement coming from Boomi.

    You can increase this limit by setting the com.boomi.container.connector.sizeLimitedUpdateOperation.maxSize property on your Atom. Using a value of -1 means documents can be of any size. Boomi documents the above property here: https://help.boomi.com/bundle/integration/page/r-atm-Properties_panel_Advanced_tab.html

    I hope this helps someone at some point. I realize this answer is coming a bit late ;)

  • cmorneau
    cmorneau Member, Employee Posts: 7 Solace Employee

    Also, based on the error message: "SEND's operation combined incoming documents", the SEND is using the Persistent Transacted mode.
    In this mode, the size limitation applies to the entire transaction. So if a batch of 256 documents is processed by the SEND, the operation fails when the combined size of all documents within the transaction exceeds the limit.

    In Persistent Non-Transacted and Direct modes, the limit applies to single documents.

  • Tamimi
    Tamimi Member, Administrator, Employee Posts: 471 admin

    Hey @Poornima I have updated the question title and the tags to reflect your question, feel free to add any other tag 👍