Try PubSub+

Tibco BusinessWorks 6.x integration with Solace

Hi, I learnt from the link (https://docs.solace.com/Developer-Tools/Integration-Guides/Solace-JMS-Integration-TIBCO-ActiveMatrix-BusinessWorks.pdf) that Solace can be integrated with Tibco BusinessWorks 5.x. But not able to find any materials on how to integrate Solace with Tibco BusinessWorks 6.x. Is there a way to integrate BW 6.x to Solace?

Comments

  • AaronAaron Member, Moderator, Employee Posts: 285 Solace Employee

    I'm not aware of anyone getting it to work. Yeah, BW5 no problem, but they really changed things around a lot for 6... if I remember, adding a custom JMS provider is a lot harder..? But in theory, it should work.

    Maybe we'll hear something more positive from someone who knows better..?

  • SkiniSkini Member, Employee Posts: 4 Solace Employee

    To connect to Solace you need to create a JNDI connection as a first step.
    When you connect the JNDI connection it will create a custom jms provider where you need to define the default Jndi details
    "com.solacesystems.jndi.SolJNDIInitialContextFactory"
    Also you need to add the few properties as a prerequisite for the JMS connection to work.
    Attaching JNDI and JMS resources for reference.

  • SkiniSkini Member, Employee Posts: 4 Solace Employee
    edited July 28 #4

    Also ensure the requisite Solace JAR files are there in the ext class path and the lib folder of the custom jms provider plugin.

  • AaronAaron Member, Moderator, Employee Posts: 285 Solace Employee

    @Skini which version of BW did you test with? I couldn't get it working, but this was about 3 years ago.

  • SkiniSkini Member, Employee Posts: 4 Solace Employee

    Hi Aaron,
    This was tested with the trial version of BWCE.

  • kvramkumarkvramkumar Member Posts: 4

    Hi Skini,

    Thanks for the steps. I am able to connect to the Solace instance at design time. But at runtime (running in BusinessStudio) it complains that the "javax.jms.JMSException: No JNDI implementations available".

    I have added the jars in lib folder and also added them to ext classpath, but still getting the same error.

    JNDI Config:

    JMS Config:

    In debug console below log is printed:

    <>@BWEclipseAppNode&gt; 2021-08-10T12:36:15.793 INFO [main] com.tibco.bw.frwk.engine.BWEngine - TIBCO-BW-FRWK-300002: BW Engine [Main] started successfully.
    2021-08-10T12:36:16.096 INFO [Framework Event Dispatcher: Equinox Container: 508b446d-a9f9-001b-1c12-9f8cb4f206d0] com.tibco.thor.frwk.Deployer - TIBCO-THOR-FRWK-300001: Started OSGi Framework of AppNode [BWEclipseAppNode] in AppSpace [BWEclipseAppSpace] of Domain [BWEclipseDomain]
    2021-08-10T12:36:16.194 INFO [Framework Event Dispatcher: Equinox Container: 508b446d-a9f9-001b-1c12-9f8cb4f206d0] com.tibco.thor.frwk.Application - TIBCO-THOR-FRWK-300018: Deploying BW Application [tibco_bw_sample_binding_rest_basic_service_application:1.0].
    2021-08-10T12:36:25.748 INFO [Framework Event Dispatcher: Equinox Container: 508b446d-a9f9-001b-1c12-9f8cb4f206d0] com.tibco.thor.frwk.Application - TIBCO-THOR-FRWK-300021: All Application dependencies are resolved for Application [tibco_bw_sample_binding_rest_basic_service_application:1.0]
    2021-08-10T12:36:25.754 INFO [Framework Event Dispatcher: Equinox Container: 508b446d-a9f9-001b-1c12-9f8cb4f206d0] com.tibco.thor.frwk.Application - Started by BusinessStudio, ignoring .enabled settings.
    2021-08-10T12:36:27.485 ERROR [pool-7-thread-1] c.t.b.thor.runtime.model.Constituent - The following error has occurred for "name: tibco_bw_sample_binding_rest_basic_service version: 1.0.0.qualifier bundle name: tibco_bw_sample_binding_rest_basic_service " which needs to be resolved.
    2021-08-10T12:36:27.486 ERROR [pool-7-thread-1] c.t.b.thor.runtime.model.Constituent - TIBCO-BW-FRWK-600053: Failed to initialize BW Component [ComponentProcess].
    com.tibco.bw.core.runtime.api.BWEngineException: TIBCO-BW-CORE-500232: Failed to initialize BW Component [ComponentProcess], Application [tibco_bw_sample_binding_rest_basic_service_application:1.0] due to activity initialization error.
    com.tibco.bw.core.runtime.ActivityInitException: TIBCO-BW-CORE-500616: Failed to initialize the activity [JMSSendMessage1] in process [tibco_bw_sample_binding_rest_basic_service.Books], module [tibco_bw_sample_binding_rest_basic_service] due to activity lifecycle error.
    com.tibco.bw.palette.jms.runtime.fault.JMSActivityLifeCycleFault: TIBCO-BW-PALETTE-JMS-500001: Invalid configuration data. JMS connection reference is not specified..
    javax.jms.JMSException: No JNDI implementations available

    Can you please help me in identifying the issue if I am missing any steps?

    Thanks and regards,
    Ram.

  • SkiniSkini Member, Employee Posts: 4 Solace Employee

    Hi Ram,
    Did you enable/check the JNDI plugin while running the application in debug mode. You will have to check it explicitly while running the app. Can you try that once and let me know.

  • kvramkumarkvramkumar Member Posts: 4

    Hi Skini,

    Thanks for your directions. I am able to connect and send messages now.

    Thanks and regards,
    Ram.

Sign In or Register to comment.