How to set ssl validate certificate to false in python

Options
DhyanandraSingh
DhyanandraSingh Member Posts: 3
edited February 2022 in Connectors & Integrations #1

I am Implementing Solace pubsub solution in python and trying to disable ssl_validate_vertificate . It is working fine in Java but not how to set same in python I tried this way:

"solace.messaging.ssl_validate_certificate":False

"solace.messaging.ssl_validate_certificate_date":False

But it's not working. getting error "Session creation unsuccessful, failed to load trust store."

Tagged:

Comments

  • Tamimi
    Tamimi Member, Administrator, Employee Posts: 499 admin
    Options

    Hey @DhyanandraSingh ! in your broker properties config, can you try to disable ssl validation using
    "solace.messaging.tls.cert-validated": False and "solace.messaging.tls.cert-validated-date": False. Let me know if this solves your issue!

  • DhyanandraSingh
    DhyanandraSingh Member Posts: 3
    Options

    Thanks @Tamimi, It worked...