Queue not able to send expiry message to DMQ

bikash Member Posts: 4


I created 2 message queue

1) Main_Queue


The main queue has been configured 'DEAD_MSG_QUEUE' as DMQ name and 'Respect TTL enabled' with Maximum TTL (sec) as 180 sec.

A producer is sending a message with DMQEligible to true and when the trough dashboard i can verify that message properties for DMQEligible set correctly to True.

But the message is not moving to DEAD_MSG_QUEUE when I checked stats for the main queue I am seeing this

Attempted move to DMQ due to Expiry, Failed for all messages expired.

Is there any other setting I am missing here?



  • TomF
    TomF Member, Employee Posts: 405 Solace Employee

    Hi @bikash,

    Can you check your DEAD_MSG_QUEUE is able to receive messages? Is it enabled, for instance? Can you send messages directly to it?

  • bikash
    bikash Member Posts: 4

    Hi @TomF ,

    Yes I can send messages directly to DEAD_MSG_QUEUE 

  • bikash
    bikash Member Posts: 4

    Some images of my configuration

  • jmahrok
    jmahrok Member Posts: 5

    Hi @bikash,

    Bind the DMQ to main queue , and pass the DMQ name without '#'.

  • bikash
    bikash Member Posts: 4

    @jmahrok ,

    I tried passing the name without # but got the same result.

  • himanshu
    himanshu Member, Employee Posts: 67 Solace Employee


    Please make sure to do the following:

    1. Name of DMQ should be exactly the same as what you specify in the DMQ setting (remove # if you don't have it in the name of the DMQ).
    2. Published messages must have DMQ Eligible setting enabled. Messages that are not DMQ eligible will not be forwarded to DMQ.

    Hope that helps.

This Month's Leaders