Configuring a persistent queue in Enterprise Evaluation GCE image via CLI

Peter Member Posts: 5

I've just installed Enterprise Evaluation so I can test an application that needs to connect to a persistent queue. When I try, it tells me that "Assured message delivery is not available on this channel." Looking at the documentation, it looks like I need to either configure the system to use the internal HD or an external HD, but from configure/hardware/message-spool in the CLI, I don't have access to either the 'disk-array' or 'internal-disk' commands. Are Guaranteed Delivery messages not supported in the trial version?



  • uherbst
    uherbst Member, Employee Posts: 121 Solace Employee

    You are connecting to which client-username ?
    Have you configured something inside the according client-profile ?

    (if you use client-username "default" in message-vpn default: Please show output of
    show client-profile default message-vpn default detail

  • Peter
    Peter Member Posts: 5

    Here's what I get (attached)

  • uherbst
    uherbst Member, Employee Posts: 121 Solace Employee

    Hi Peter,

       Guaranteed Message Send             : deny
        Guaranteed Message Receive          : deny
        Guaranteed Endpoint Create          : deny

    You have to change these settings in the client profile to allow to enable guaranteed messaging.

  • Peter
    Peter Member Posts: 5

    Thank you, that looks like it's working now.

  • Peter
    Peter Member Posts: 5

    (G-Guaranteed, D-Direct, C-Control)
    Queue Max Depths
    G-1 : 20000 work units
    D-1 : 20000 work units
    D-2 : 20000 work units
    D-3 : 20000 work units
    C-1 : 20000 work units
    Priority Queue Min Burst
    G-1 : 255 messages
    D-1 : 4 messages
    D-2 : 4 messages
    D-3 : 4 messages
    C-1 : 4 messages
    Message Spool
    Guaranteed Message Send : deny
    Guaranteed Message Receive : deny
    Guaranteed Endpoint Create : deny
    Guaranteed Endpoint Durability : all
    Transacted Sessions : deny
    Cut-Through Forwarding : deny
    Max Transacted Sessions : 10
    Configured Max Transacted Sessions : 10
    Max Transactions : 5000
    Configured Max Transactions : 5000
    Max Endpoints per client-username : 1000
    Configured Max Endpoints per c-u : 1000
    Max Egress Flows : 1000
    Configured Max Egress Flows : 1000
    Max Ingress Flows : 1000
    Configured Max Ingress Flows : 1000
    Reject Message to Sender on
    No Subscription Match : no
    Copy-from Queue :
    Copy-from-template Queue :
    Copy-from Topic Endpoint :
    Copy-from-template Topic Endpoint :
    Allow Downgrade to Plain Text : Yes
    Enabled : Yes
    MSS : 1460
    Initial Window : 2
    Maximum Window : 256 KB
    Count : 5
    Idle : 3 seconds
    Interval : 1 seconds

    Enabled : No
    Max Topics : 256
    Delay : 0 milliseconds
    Web Transport
    Inactive Timeout : 30 seconds
    Max Web Payload : 1000000 bytes
    Allow Clients When Standby : No
    Max # Connections per client-username : 10000
    Service SMF : 10000
    Web Transport : 10000
    Max # Subscriptions : 500000
    Configured Max # Subscriptions : 500000
    Allow Bridge Connections : No
    Allow Shared Subscriptions : No

    Event Threshold Set Value Clear Value

    Subscriptions 80%(400000) 60%(300000)
    Connections per client-username 80%(8000) 60%(6000)
    Service SMF 80%(8000) 60%(6000)
    Service WEB 80%(8000) 60%(6000)
    Provisioned endpt spool usage (%) 80 60
    Transacted sessions 80%(8) 60%(6)
    Transactions 80%(4000) 60%(3000)
    Endpoints per client-username 80%(800) 60%(600)
    Egress flows 80%(800) 60%(600)
    Ingress flows 80%(800) 60%(600)

    User Type - CU (client-username)
    UB (unidirectional bridge [remote message-vpn])
    RB (replication bridge)
    AG (authorization group)

  • [Deleted User]
    [Deleted User] Posts: 25

    Hey @Peter, looks like you tried to post that comment above a couple times and it got flagged by our spam filters. I've released it and updated our filters to allow your posts and comments through so you shouldn't run into this issue again. Glad you were able to find a way to post the output and Uli could help out!

  • Peter
    Peter Member Posts: 5

    Thanks, Trish. Yes, that's the text I eventually posted as an attachment. It simply vanished every time I tried to enter it, so I thought it was getting silently rejected for something.