Pubsub+ in docker - cannot open admin console on web browser after creating pubsub+ container

Options
lukmanul
lukmanul Member Posts: 7

Hi,
I am testing pubsub+ in docker that I pull from docker hub after that running docker container and open port for admin as well. But when I try to access admin console from http://localhost:8080, it's nothing happen. So what should I check first to get the issue?

Thanks in advance.
Lukman

Best Answer

Answers

  • arih
    arih Member, Employee Posts: 125 Solace Employee
    Options

    Hi @lukmanul

    For docker, you can try to see 'inside' first. I'll usually just get in to the broker, something like:

    $ docker exec -ti <mycontainername> /bin/bash
    # cli
    solace> show services
    

    and see if the 8080 is U (for up) or if there's any error.

    And you can try from local just to rule out networking issues:

    $ curl localhost:8080
    it should give you some HTML codes, or error code if it's not running.

    You can also quickly check the docker logs
    $ docker logs -50f <containername>

    cheers,
    Ari

  • lukmanul
    lukmanul Member Posts: 7
    Options

    Hi @arih,
    The port 8080 is actually Up.

    I think this is because networking issues. Connection refused.

    Thanks.

  • TomF
    TomF Member, Employee Posts: 408 Solace Employee
    Options

    @lukmanul, I'd agree it looks like a network issue. The first step is to check docker is exposing port 8080 or if it has been mapped to another port. The easiest way to do that is to use "docker inspect" and check the "HostConfig" section, subsection "PortBindings":
    docker inspect pubSubStandardSingleNode
    Gives me:

    ...
    "HostConfig": {
    ...
    "PortBindings": {
    ...
    "8080/tcp": [
                        {
                            "HostIp": "",
                            "HostPort": "8080"
                        }
    

    So I can tell that 8080 on my container/broker is mapped to 8080 on my localhost. You may find 8080 on your container has been mapped to a different port, say 8081.

  • lukmanul
    lukmanul Member Posts: 7
    Options

    Hi @TomF,
    This is the detail of docker inspect mycontainername command:

    am I in the correct path? or any other configuration need to be set?
    Thanks.

  • TomF
    TomF Member, Employee Posts: 408 Solace Employee
    Options

    No, that looks good. The next question: is there some other process on your machine using port 8080?

  • lukmanul
    lukmanul Member Posts: 7
    Options

    There is no conflict port on my local PC, I have make sure them by checking listening port running on my resource monitor.

  • arih
    arih Member, Employee Posts: 125 Solace Employee
    Options

    that looks good to me.

    how about trying with other browser or incognito mode? And maybe try with your actual IP address instead of localhost? I've had some issues with localhost with Safari/macOS, just to rule that out as I don't have experience with this on Windows.

  • lukmanul
    lukmanul Member Posts: 7
    #10 Answer ✓
    Options

    Hi all,
    I got it, it's running well when I change my IP to http://192.168.99.100:8080 instead of http://localhost:8080. Simply just checking docker info and then got this detail IP :)

  • TomF
    TomF Member, Employee Posts: 408 Solace Employee
    Options

    Thanks for the update @lukmanul. It's always good to hear people are able to get working and what the problem was...