System scaling using helm chart

tiwaabh Member Posts: 5
edited March 2023 in PubSub+ Event Broker #1


I have configured solace in my dev env(using helm chart) and currently it only allows upto 100 queues/endpoints creation. To scale I tried setting systemScaling values to :

But it doesn't seem to be working.

I setup solace in my laptop in docker and added these as --env system_scaling_maxconnectioncount=1000 --env system_scaling_maxqueuemessagecount=1000 --env messagespool_maxspoolusage=1000

Here, it seems to have worked in my laptop.

Is there any step, I am missing that is required for making these changes effective when using helm charts.



  • Dennis Brinley
    Dennis Brinley Member, Employee Posts: 3 Solace Employee

    Hi - It appears to me that the override values are not being applied to the helm chart. Are you over-riding the values file using -f values.yaml? I am able to use the following command to apply over-rides when installing the pubsubplus chart. Can you try using this command as a model?

    helm install ********* solacecharts/pubsubplus \
      --namespace solace \
      --set storage.size=30Gi \
      --set serviceAccount.create=false,********-sa \
      --set solace.systemScaling.maxConnections=1000 \
      --set solace.systemScaling.maxQueueMessages=240 \
      --set solace.systemScaling.maxSpoolUsage=4000 \
      --set solace.systemScaling.cpu=2500m \
      --set solace.systemScaling.memory=7Gi

    Note that you should go to the resource calculator page to assist with setting the resource values:

    The max connections and max queued messages values must be from a set of discrete values. For example, max queue messages can be 100, 240, or 3000 (million) messages.