Try PubSub+
If you haven't already, check out our new Developer Portal! You'll find useful information about Solace PubSub+ as well as handy resources to get you started.

connect solace to kafka (not confluent)

eddieeddie Member Posts: 5

Hi,
I got solace pub/sub running locally. I can publish to a queue under a topic and consume from it via a subscription. I also have kafka/zookeeper running under WSL. I am trying to connect solace to standalone kafka by following Heinz Schaffner's video: https://docs.solace.com/Developer-Tools/Integration-Guides/Kafka-Connect.htm using the Solace source connector.

sudo bin/connect-standalone.sh config/connect-standalone.properties solace.properties

returns this error: Failed to connect to and describe Kafka cluster. Check worker's broker connection and security properties.
I am not sure if I had considered solace.properties correctly. I took the one downloaded from Heinz and replaced the sol.host/sol.username/sol.password/sol.vpn/sol.topic with my own and left everything else alone including all the sol.ssl fields. There may be other things I missed too.
Any help will be appreciated.
Eddie

Comments

  • HeinzHeinz Member, Employee Posts: 7 Solace Employee

    Eddie:
    The first thing a Connector checks is the Kafka access. As you reported this failed, so it never gets to try the Solace connection. The error you received usually is a result of failing to authenticate to the Broker. Have you enabled any authentication or secure transport for your Kafka Brokers? If so, then the connect-standalone.properties file must be updated to reflect the security requirements from the Connect Cluster.
    Heinz

  • eddieeddie Member Posts: 5

    Heinz,
    Thank you so much for responding. I got yanked away to do something else. Will get back to this when I have a chance.
    Eddie

  • AaronAaron Member, Moderator, Employee Posts: 62 Solace Employee

    Hey @eddie ... any update here? Would be good to know if you got this working.

Sign In or Register to comment.