connect solace to kafka (not confluent)

eddie Member Posts: 5

I got solace pub/sub running locally. I can publish to a queue under a topic and consume from it via a subscription. I also have kafka/zookeeper running under WSL. I am trying to connect solace to standalone kafka by following Heinz Schaffner's video: using the Solace source connector.

sudo bin/ config/

returns this error: Failed to connect to and describe Kafka cluster. Check worker's broker connection and security properties.
I am not sure if I had considered correctly. I took the one downloaded from Heinz and replaced the with my own and left everything else alone including all the sol.ssl fields. There may be other things I missed too.
Any help will be appreciated.


  • [Deleted User]

    The first thing a Connector checks is the Kafka access. As you reported this failed, so it never gets to try the Solace connection. The error you received usually is a result of failing to authenticate to the Broker. Have you enabled any authentication or secure transport for your Kafka Brokers? If so, then the file must be updated to reflect the security requirements from the Connect Cluster.

  • eddie
    eddie Member Posts: 5

    Thank you so much for responding. I got yanked away to do something else. Will get back to this when I have a chance.

  • Aaron
    Aaron Member, Administrator, Moderator, Employee Posts: 541 admin

    Hey @eddie ... any update here? Would be good to know if you got this working.