Try PubSub+

replay of message by clinet using JS web messaging API

dhanarupadhanarupa Member Posts: 4

I tried repalying the message using the messagereplay.html file.
[17:17:56] Starting message replay for queue: TQUEUEREP1
[17:17:56] === Error: the message consumer could not bind to queue "TQUEUEREP1" ===
Ensure this queue exists on the message router vpn
The queue exists on the router, i tried another queue as well, it did not work. am i missing something

Tagged:

Answers

  • TomFTomF Member, Employee Posts: 78 Solace Employee

    Hi @dhanarupa I did some trials and you're right, you will get this error even if the queue does exist. The problem is that replay hasn't been enabled - you need to create the replay log first.
    I have 2 hours to get a pull request sorted, I'll see what I can do...

  • dhanarupadhanarupa Member Posts: 4

    Is it a problem with the code? I had replay enabled on the VPN. If it is code please let me know once fixed in GIT, I will try with latest update.
    Also I tried replay with Java API, I am able to replay on the Exclusive Queue, but getting on non-exclusive queue saying that replay cannot be done on non-exclusive queues. Is there a limitation on that?

  • AaronAaron Member, Moderator, Employee Posts: 91 Solace Employee
    edited July 26

    Hi @dhanarupa ... during my weekly office hours, I tried to debug what you were seeing. I confirmed there was an issue specifically with a JavaScript API requesting replay to a non-exclusive queue. But I also figured out that if you request the Replay administratively, it will work.

    If you want to watch the video, check: https://www.youtube.com/watch?v=vb2gm0N78Iw&t=1510s (debugging start... might want to fast forward)
    https://www.youtube.com/watch?v=vb2gm0N78Iw&t=3620s - admin replay to a non-exclusive queue

Sign In or Register to comment.