RDP: status of outgoing REST consumer status remains down

Options
sjaak
sjaak Member Posts: 103 ✭✭✭
edited March 2021 in PubSub+ Event Broker #1

Hi,
We're testing the RDP functionality using this example https://solace.com/blog/event-broker-cloud-lambda-aws-api-gateway/. Status of outgoing REST consumer status remains down. We have tried many different settings like Service mode "messaging" and "gateway". Any tips? I also tried the CLI to enable the outgoing REST service. But it fails. Any ideas?

Best Answer

  • sjaak
    sjaak Member Posts: 103 ✭✭✭
    edited March 2021 #2 Answer ✓
    Options

    We just fixed it by uploading 3 PEM's. As a Boomi developer, I not used anymore to upload certs because the Boomi Java stack already included the most used "Certificates Authorities". I need to reset by brain :wink:

Answers

  • rlawrence
    rlawrence Member, Employee Posts: 14 Solace Employee
    Options

    Hi,
    If it's a connectivity issue to the external REST endpoint you should see the last failure reason for the REST Consumer on the "Stats" tab under the "Details" sub-tab. If however, the external REST endpoint is returning an HTTP error you may see the the returned error information in the RDP logs. To check the logs use the CLI command: "show log rest rest-delivery-point errors wide"
    HTH

  • sjaak
    sjaak Member Posts: 103 ✭✭✭
    edited March 2021 #4
    Options

    Found this: Local SSL handshake failed: Server certificate verification failed: self signed certificate in certificate chain
    What does it mean?

  • rlawrence
    rlawrence Member, Employee Posts: 14 Solace Employee
    Options

    Likely due to missing cert configured in the Solace broker, try loading the root CA cert used by the external REST endpoint on the broker. If it's a cloud service you can load this through the Cloud Console under "Manage" and "Certificate Authorities". Note you will probably also need to configure the trusted common name used in the cert under "TLS Options" for the REST Consumer.

  • sjaak
    sjaak Member Posts: 103 ✭✭✭
    edited March 2021 #6 Answer ✓
    Options

    We just fixed it by uploading 3 PEM's. As a Boomi developer, I not used anymore to upload certs because the Boomi Java stack already included the most used "Certificates Authorities". I need to reset by brain :wink:

  • nram
    nram Member, Employee Posts: 80 Solace Employee
    Options

    Hi @sjaak , This usually mean we are missing certificate authorities. Please obtain the certificates of the certificate authorities (root CAs) of the REST Consumers and install them as certificate authorities.

  • sjaak
    sjaak Member Posts: 103 ✭✭✭
    Options

    Hi @nram. I already solved the issue last week. See the best answer. The problem was indeed related to missing certificates.

  • nram
    nram Member, Employee Posts: 80 Solace Employee
    Options

    Oh Yikes! Thats the danger of reading just the last post on the thread. :-) Thanks for the update.

  • marc
    marc Member, Administrator, Moderator, Employee Posts: 923 admin
    edited March 2021 #10
    Options

    glad you figured it out @sjaak and sorry about the confusion @nram (I get confused too 😜). We're working on some updates to this site that will both promote the best answer to the top of the thread but also leave it in place in the thread. Also hopefully some styling to make the answer stand out :)