RDP consumer failed with Local SSL handshake failed: certificate chain too long

Hi ,

We were trying to configure an RDP but encountered this error "Local SSL handshake failed: Server certificate verification failed: certificate chain too long"

The backend cert chain length is 5. Is it supported 9.12 version on cloud and if so are we missing some configuration.


Regards,

Rajesh

Best Answer

  • swenhelge
    swenhelge Member, Employee Posts: 72 Solace Employee
    #2 Answer ✓

    Hi @kdrajeshbabu

    This is not related ot the broker service.

    AFAIK this setting is managed by the cloud team, it's not editable using the Management UI.

    You can request a change to this value by raising a support request - via the cloud console "help" menu.

    Unfortunately the default setting is "3" which is too low e.g. for a number of AWS services.

Answers

  • swenhelge
    swenhelge Member, Employee Posts: 72 Solace Employee
    #3 Answer ✓

    Hi @kdrajeshbabu

    This is not related ot the broker service.

    AFAIK this setting is managed by the cloud team, it's not editable using the Management UI.

    You can request a change to this value by raising a support request - via the cloud console "help" menu.

    Unfortunately the default setting is "3" which is too low e.g. for a number of AWS services.

  • kdrajeshbabu
    kdrajeshbabu Member Posts: 6

    Hi @swenhelge , thanks for the response. Yea i reached out to the cloud team and was able to update the broker config(max-certificate-chain-depth) from cli.