Try PubSub+

About changing sol-jms version in solace-jms-spring-boot-starter 4.1.0

philipchoiphilipchoi Member Posts: 1

Hello,

Due to some reasons, I need to use sol-jms 10.11.

However, I want to use solace-jms-spring-boot-starter for my project but the latest version of the starter (4.1.0) is using sol-jms 10.8.1.

I want to change the sol-jms version by:

<dependency>
    <groupId>com.solace.spring.boot</groupId>
    <artifactId>solace-jms-spring-boot-starter</artifactId>
    <version>4.1.0</version>
    <exclusions>
        <exclusion>
            <groupId>com.solacesystems</groupId>
            <artifactId>sol-jms</artifactId>
        </exclusion>
    </exclusions>
</dependency>

<dependency>
    <groupId>com.solacesystems</groupId>
    <artifactId>sol-jms</artifactId>
    <version>10.11.0</version>
</dependency>

After changing the version, will there any compatibility issues?
Or, should I remove solace-jms-spring-boot-starter 4.1.0 and only use sol-jms 10.11?

Thanks a lot!

Answers

  • marcmarc Member, Administrator, Moderator, Employee Posts: 472 admin

    Hi @philipchoi,

    I believe you're good to go but will follow-up internally and make sure

    Have a great weekend!

  • marcmarc Member, Administrator, Moderator, Employee Posts: 472 admin

    Hi @philipchoi,

    Hope you had a great weekend.

    Most likely you're good to go, but you'll need to check what version of SolOS your event brokers are running. There is a known issue (SOL-47779) with SolOS v9.8.1.19 and sol-jms 10.11.0 (or JCSMP 10.11.0), but the issue only exists in that exact version. There is no known compatibility issues with SolOS versions earlier or later than 9.8.1.19.

    Cheers!

Sign In or Register to comment.