I'm not able to create a subscription topic under '#telemetry-trace' queue. How can I do it?

Options
Aishwarya
Aishwarya Member Posts: 6

I'm using open-telemetry framework. I have created a queue named '#telemetry-trace'. Now I'm trying to create a subscription topic for that queue and I'm getting an error 'The #telemetry-trace queue may not be configured'

Does anyone know how to solve this error?

Thanks in Advance!

Best Answers

  • marc
    marc Member, Administrator, Moderator, Employee Posts: 923 admin
    #2 Answer ✓
    Options

    Hi @Aishwarya,

    # is used to specify reserved internal queues for Solace and you should not start your queue name with a # . Please change your queue name :)

    From the docs:

    <name> is a queue name of up to 200 characters (only reserved queue names can begin with # and invalid characters are '<>*?&;)


  • marc
    marc Member, Administrator, Moderator, Employee Posts: 923 admin
    #3 Answer ✓
    Options

    Hi @Aishwarya,

    I don't know exactly what it is off the top of my head but it looks like some sort of permissions or feature not enabled issue. Check that rest messaging is enabled and that your client-profile can send to that topic (ACL) as a starting point.

    If that doesn't resolve it please make a new post since this is a different issue than the original in this thread. I will be OOO for the next few weeks and that will get fresh eyes on the issue.

    Hope that helps!

Answers

  • marc
    marc Member, Administrator, Moderator, Employee Posts: 923 admin
    #4 Answer ✓
    Options

    Hi @Aishwarya,

    # is used to specify reserved internal queues for Solace and you should not start your queue name with a # . Please change your queue name :)

    From the docs:

    <name> is a queue name of up to 200 characters (only reserved queue names can begin with # and invalid characters are '<>*?&;)


  • Aishwarya
    Aishwarya Member Posts: 6
    Options

    Hello @marc Thank you so much for your help :)

  • Aishwarya
    Aishwarya Member Posts: 6
    Options

    Now I'm stuck with new issue:

    <solace-error-response>

      <code>403</code>

      <reason>

        <![CDATA[Unauthorized]]>

       

      </reason>

      <detail>

        <![CDATA[

    SMF ClientCtrl response error

    ]]>

       

      </detail>

      <internal-use>2:13503</internal-use>

    </solace-error-response>


    I'm trying to send messages through postman. But failed to do so.


    Do you have some ideas ?

  • marc
    marc Member, Administrator, Moderator, Employee Posts: 923 admin
    #7 Answer ✓
    Options

    Hi @Aishwarya,

    I don't know exactly what it is off the top of my head but it looks like some sort of permissions or feature not enabled issue. Check that rest messaging is enabled and that your client-profile can send to that topic (ACL) as a starting point.

    If that doesn't resolve it please make a new post since this is a different issue than the original in this thread. I will be OOO for the next few weeks and that will get fresh eyes on the issue.

    Hope that helps!

  • Aishwarya
    Aishwarya Member Posts: 6
    Options

    Hey @marc,

    Thank you so much for your help. It was an issue of permissions.

    Now it's working fine :)

    Kind Regards,

    Asishwarya.