TLS port not working after TLS enabling on a deployed Solace Broker



I have deployed a Solace Broker software helm chart which I've found on artifact hub ->

There I have accessed a "Default values" section where I have downloaded a yaml configuration file in order to adjust it according to my needs. As a default setting we have a disabled TLS property (image below) ->

At this point the deployment has been successful, and I've managed to access Broker Manager UI via port 8080

As a next step I wanted to enable the TLS. I've set "enabled" value to TRUE to activate it and I've generated tls.key and tls.crt locally via openSSH and placed their values in a separate Secret.yaml file created by me, because we have a mandatory property in values.yaml I mentioned above, called "serverCertificatesSecret" that needs to be filled in with a Secret name that contains certificates (see the image below). At the end I've applied that Secret.yaml file to the Kubernetes as a resource

After that, I've redeployed everything. I've seen on Kubernetes that there is a successful mounted volume containing that Secret. The deploy is a green one, but no port runs as of this moment. I've managed to "access" only port 1943 - used for Broker Management over TLS but I got a "400 Bad Request" (image below)

The rest of ports do not load. My questions is: what exactly has been misconfigured, where is the missing point? How do I get a successful deployment with an enabled TLS and a running port? Thank you in advance! 🙂